MIDI Pitch Off in Pro Tools Session

Mindwatering Incorporated

Author: Tripp W Black

Created: 01/01 at 09:45 PM

 

Category:
Pro Tools
Plug-Ins

Issue:
Pro Tools 2020.12. Mac

Recorded multiple keyboards, a Korg and a Nord, with session data and MIDI.
Decided to swap out one of the sounds for a instrument plugin, but the MIDI is off (about 1/3 step, around 50 cents at middle C).

- The keyboards are still tuned for 440 Hz.
- The Pitch controls in the plugins (that have one) are at 0, no modification.
- It's not a problem with the MIDI file, because click the middle C on the virtual keyboard of the plugins exhibited the same issue.


Solution:
None found after spending hours trying. Only accomplishment is that the MIDI pitch issue is between 1/3 and 1/2 of a step, around 35 or so cents.


Discoveries:
Only thing known is that the issue is session (ptx file) specific.

Created 4 throw-away test sessions at 44.1 or 48 K with 24bit or 16 bit, and all four combinations/new sessions were fine/correct/on pitch with the MIDI coming off the virtual keyboard and the actual Nord and Korg.
Imported one of the "bad" MIDI tracks from the keyboard and the notes played by the MIDI were pitched correctly with all for test sessions.

Created sessions using older MW SMS template, and one of the stock templates at 48.1 and 24 bit, and both of the sessions created had MIDI with correct pitch from both "real" and "virtual" keyboards.
Created session using current template, and it also performed the MIDI at the correct pitch.

2 out of about the 10 sessions we created since June, have this issue. Both of the sessions with the issue were created in October. All the other sessions were created August or earlier. All of these sessions were created before Pro Tools 2020.12, but only the two in October show the issue.


Work-around:
Opened a new session from our current MW SMS session templates.
Preformed an import of all audio tracks, mix tracks, and MIDI tracks from the old session.

The new session has correct pitch.



previous page